Catégories: "Systèmes"

Mac OS X Leopard: l'essentiel

Apple a dévoilé hier, lors de la keynote de la WWDC 06, un certain nombre de fonctionnalités de Léopard, la prochaine version de Mac OS X.

Apple en a profité pour railler Microsoft la prochaine version de Windows (Vista) traine depuis des années... et ressemble étrangement à Mac OS X sur bien des points. Il y a deux ans, Apple avait affiché des panneaux publicitaires dans le hall de la WWDC marqués "Redmond, péréparez vos photocopieuses" (Redmond c'est le siège de Microsoft pour ceux qui viennent de Mars). Là ils ont juste dit "On ne pensait pas qu'ils le feraient vraiment!" :>>

Apple a également présenté ses nouveaux serveurs double-Intel-Xeon-Core-2-duo-64-bits. (Respirez). En gros, il y a 4 coeurs 64 bits et ça va très vite. Cette fois-ci, c'est Dell qui en a pris pour son grade...

Mais l'essentiel concernait Léopard...

Beaucoup beaucoup de nouvelles fonctions plus ou moins gadget (à découvrir sur le site Apple) mais aussi quelques vraies innovations vraiment utiles. Voici l'essentiel à mon sens:

Max OS X Time Machine
Max OS X Time Machine

Time Machine: "la machine a remonter le temps". Il s'agit d'un utilitaire de backup intégré qui a la bonne idée de s'activer automatiquement ainsi que le bon goût de présenter une interface de restauration très graphique (voir copie d'écran) et conviviale. Elle permet par exemple de restaurer sélectivement un simple contact du carnet d'adresse. Il y a donc une API de backup dont toutes les applications peuvent éventuellement tirer parti.

Post complet »

mail on Debian

So... I guess I thought I was smart enough to set up a Debian server all by myself... and it looks like I'm not even able to get basic email to work! :roll: Bleh...

I could set up apache, php, mysql and have everything working... but email ? What the hell is going on?

I sorta had exim4 installed automatically while apt-get installing mysql-4.1 . I also installed mutt so I could "read" any mail. But that damn thing won't save any email to /var/mail !! I think there should be a file named 'root' (at least) in there, but there is not.

All I know, is that I can use 'mail' to send email to an external machine. But I can't use mail to send a local mail to root.

I get lines like these in /var/log/exim4/mainlog:

2006-05-27 01:18:17 1FjlZR-0007Wy-Gx == /var/mail/mail (root@ns34611.ovh.net) <root@ns34611.ovh.net> R=mail4root T=address_file defer (13): Permission denied: creating lock file hitching post /var/mail/mail.lock.ns34611.ovh.net.44778cb9.0000711b (euid=8 egid=8)

The exim process seems to be running under Debian-exim4 and the permission for /var/mail seems to be drwxr-sr-x root root

Now of course I can make it work by funkying around with the permissions of that folder, but that doesn't feel right... Besides I wonder what magic that 's' is trying to accomplish...

Is there a caring soul out there willing to show me the light? I'm so lost right now... :| Thanx!! ;)

Update:

I think I need to log what I did here... might get useful someday...

Full story »

3 moniteurs: pas si simple :(

Arrrgl!!! Je viens de passer l'après-midi à essayer d'allumer 3 moniteurs avec un seul PC. La motivation est simple: j'ai toujours une fenêtre cachée au moment où j'aurais besoin de la voir (le log d'erreurs JavaScript par exemple). La solution.... pas si simple.

Enfin si, il y a une solution simple: la carte ATI FireMV avec 4 sorties DVI. Mais ça coute 650 € et c'est pas gagné que je puisse faire passer ça en note de frais! :roll:

Du coup j'ai essayé de ruser... J'ai une carte mère ASUS A8N-SLI Premium. C'est une carte SLI, ce qui veut dire qu'il y a 2 slots PCI express (PCIe), théoriquement destinés à mettre 2 cartes vidéo identiques afin qu'elles se partagent le boulot et affichent plus de détails plus vites dans les jeux.

Moi je m'en tamponne pas mal d'avoir 2 cartes qui se partagent le boulot pour afficher 1 seule image. Moi ce que je veux c'est 2 cartes qui bossent côte à côte, une qui gère 2 écrans et une autre qui gère un 3ème écran! Il y en a qui ont apparemment réussi à faire ça il y a bien longtemps déjà.

Alors j'avais déjà une carte à base de ATI RADEON X800GT. Je sais, c'est une carte haute performance pour les jeux, mais je n'avais trouvé que ça avec 2 ports DVI. Et puis à côté d'une FireMV c'est presque donné! En réalité je ne sais plus combien elle m'a couté. Ceci dit, il était hos de question de racheter la même pour mettre dans le 2ème slot PCIe, ne serait-ce qu'à cause de l'imposant ventilateur qui fait du bruit (enfin pas tant que ça, mais quand même).

Du coup j'ai acheté une carte PCIe d'entrée de gamme à base de ATI RADEON X300SE en me disant que comme ça le même driver allait gérer les 2 cartes et que ça marcherait forcément mieux.

Ben non. Ya rien à faire. Windows refuse de reconnaitre qu'il y a 2 cartes installées. Pourtant j'ai bien configuré le BIOS et le "ASUS AI Selector" (ils pouvaient pas trouver plus clair... |-|) pour signifier que j'avais 2 cartes vidéo sur mes 2 ports PCIe.

J'arrive à faire marcher la X800 toute seule sur le slot 1.
J'arrive à faire marcher la X300 toute seule sur le slot 1.
Mais dès que je mets les 2 cartes, il n'y a toujours que le X800 qui soit détectée par Windows, et ceci qu'elle soit sur le slot 1 ou sur le slot 2! C'est presque comme si la X300 n'était même pas installée dans le PC (sauf que si je l'enlève du slot 1, le PC refuse de booter, donc quelque part il la voit bien.)

A mon avis il y a un problème entre le BIOS et Windows XP, parce que la 2ème carte n'apparait même pas dans le gestionnaire des périphériques, même pas sous forme d'icône point d'interrogation - périphérique inconnu.

Pfff... déprimant. :(

Du coup je crois que je vais ramener la X300 et voir si il sn'ont pas une pauvre carte PCI (pas express) à la place... :'(

2 connexions ADSL simultanées

Voilà un truc qui m'énerve depuis un bout de temps: au bureau on a 2 connexions ADSL: une chez Free et une chez Wanadoo. Bien évidemment, aucune des deux ne fonctionne correctement de manière inintérrompue entre 9h et 23h.

La solution pro serait d'avoir un routeur qui route entre les deux.

La solution "cheap" qu'on a ici consiste à brancher chaque poste sur les 2 réseaux par l'intermédiaire de 2 cartes réseau (sachant que les cartes mères arrivent maintenant avec une ou 2 interfaces réseau intégrées, ça ne revient vraiment pas cher).

Reste que Wanadoo est encore moins fiable que Free et que Windows semble insister pour passer par Wanadoo même quand il marche pas (ou mal...).

Jusqu'ici j'allais dans Paramètres > Connexions Réseau et je désactivais le réseau Wanadoo tant que je n'en avais pas besoin. Mais ça commençait à devenir un peu pénible...

Boite de dialogue "Paramètres TCP/IP avancés"

En cherchant un peu aujourd'hui, je crois que j'ai trouvé un truc qui devrait faire l'affaire: Propriétés de la connexion Wanadoo > Propriétés TCP/IP > Avancé . Là, je décoche "Métrique automatique" et je mets "Métrique de l'interface: 100".

A priori ça devrait clairement indiquer à Windows: "n'utiliser cette connexion qu'en dernier recours, si aucune autre route moins couteuse n'a été trouvée".

En tapant route print en ligne de commande, ça à l'air de faire ce que je veux, mais je vais voir à l'usage si ça rend la double connexion plus cool...

Thunderbird to Thunderbird Mail Transfer Tutorial (windows)

Best thing: it works! ;) (Tested on TB 1.0.7)