Catégorie: "Windows"

Tous ces trucs qui démarrent automatiquement dans Windows...

msconfig.exe
msconfig.exe

Pour voir la liste de toutes les saloperies qui démarrent automatiquement et ralentissent Windows: Démarrer > Executer > msconfig.exe

Mac/PC divergences de couleur...

Mac/PC divergences de couleur...

En quête de couleur

Sur mon bureau il y a 3 écrans plats (SONY SM-S95DR) rigoureusement identiques. Les réglages sont identiques et les numéros de série se suivent, ce qui permet également de présumer raisonnablement de composants électroniques “identiques". En temps normal, les 3 écrans sont reliés numériquement (DVI-D) à mon PC et affichent rigoureusement les mêmes couleurs.

Le problème du jour: éditer des images sur Photoshop (CS2) sur Mac et obtenir les mêmes couleurs à l’arrivée sur PC dans un browser web… Ben c’est pas simple!! :(

Je commence par brancher mon Mac (OS X 10.4.8 Tiger) en DVI sur l’écran du milieu et je laisse le PC sur les écrans des côtés. J’affiche le même fond d’écran et la même image PNG de test – sous ACDSee sur PC et Preview (la Visionneuse) sur Mac. Et bien sûr… rien n’est pareil!

Calibration

Je clique dans tous les sens et je fini par trouver une solution à peu près satisfaisante: sur le Mac, je vais dans les Préférences Système puis Moniteurs puis Couleur. Un profil nommé “SDM-S95DR/FR” et correspondant à mon moniteur est présélectionné. (Je me demande d’où vient ce profil? Est-ce qu’il est intégré à OS X ou bien est-ce que c’est le moniteur qui a envoyé ses valeurs par DVI au Mac. Je table sur la deuxième solution parce que ça ressemble plus à de la science fiction mais en réalité je n’en sais rien…)

Post complet »

Plaidoyer pour un meilleur clavier

Logitech Media Keyboard Elite
Logitech Media Keyboard Elite

J’utilise actuellement un clavier Logitech identique à la photo ci-dessus. C’est le moins pire que j’ai trouvé… mais on est franchement loin du clavier idéal!

Tellement loin même que je ne comprends pas pourquoi des fabricants comme Logitech ou Microsoft – qui proposent toute une gamme de claviers entre pas cher et Deluxe – n’ont toujours pas de modèle pour utilisateurs “sérieux".

Mais avant de critiquer, je voudrais quand même relever tout ce qui est bien sur mon clavier actuel:

  • Clavier plat: contrairement à ce que pensent la plupart des gens, une inclinaison style “machine à écrire” n’a absolument rien d’ergonomique. Un clavier plat, voire surélevé au niveau des poignets est bien plus reposant pour l’humain. En tout état de cause, ne dépliez pas les pieds à l’arrière du clavier. Il faut quelques jours pour s’habituer mais c’est bien mieux après, vous verrez!
  • Des vraies touches mécaniques. Quand on appuie sur une touche, on a besoin que la touche résiste un peu pour ne pas appuyer par erreur, ni appuyer deux fois au lieu d’une. Mais on a aussi besoin que les touches ne résistent pas trop sinon c’est désagréable. On a aussi besoin que la touche s’enfonce suffisamment pour “sentir” qu’on a tapé sur la touche. Logitech fait ça assez bien. Cependant, leur claviers de 2001-02 étaient meilleurs sur ce point.
  • Des touches de contrôle pour la musique. C’est bien pratique de changer de morceau, de mettre en pause ou de baisser le volume sans chercher la fenêtre du player multimédia.
  • Touches de contrôle redisposées: regardez bein les touches “page suivante"/"page précédente” et “début"/"fin” sur la photo. Elles sont redisposées de manière beaucoup plus logique que sur les claviers IBM d’origine. Surtout pour ce qui est d’aller en début et fin de ligne. Mieux encore: la touche “Delete” (suppression) a une taille double, ce qui la rend aussi grande que la touche “backspace” (retour arrière). Ca c’est vraiment pratique au quotidien! (Microsoft utilise la même disposition.)

Et maintenant tout ce qui ne va pas:

Post complet »

Un PC de développement pour 2007

Je crois que le moment est venu pour moi d'upgrader mon PC de dev... un authentique Pentium III 933 MHz overclocké à 1 Ghz de manière totalement involontaire, le tout tournant avec 512 Mo de RAM (je me rends compte maintenant que j'ai du recycler la deuxième barrette pour un autre PC...) et une paire de disques dur PATA.

Vous allez me dire (ou en tout cas, moi je vais vous le dire) ce qui compte pour le dev, c'est avant tout:

  1. Un bon écran (en l'occurrence un SONY 19" dont le backlight est réglable bien comme il faut)
  2. Un bon clavier (en l'occurrence un Logitech à fil, ce qui limite les fioritures et c'est un peu dommage, j'aurais bien aimé une molette de scroll à gauche).
  3. Une bonne souris (en l'occurrence une Logitech vintage comme on en fait plus. J'aimerais bien avoir la même sans fil, mais les souris d'aujourd'hui sont tout sauf ergonomiques. Beaucoup trop grosses en particulier)

De ce point de vue, ça va bien donc. Maintenant c'est vrai que question puissance ça commence à être limite, non seulement pour l'utilisation des IDE modernes (NuSphere PhpED dans mon cas), mais surtout pour faire tourner un SGBD (MySQL) et un serveur web (Apache + PHP) en même temps que l'environnement de dev, afin de pouvoir tester en live.

Un processeur récent me parait donc nécessaire. Ce qui va impliquer changement de carte mère, changement de RAM et changement de toute une série d'autres choses puisque les connecteurs ont changé (AGP -> PCI express, PATA -> SATA, etc...).

Plutôt que de parler d'upgrade, il serait donc probablement plus logique de parler de remplacement de PC. Seulement voilà, comment je fais pour choisir?

Post complet »

3 moniteurs: pas si simple :(

Arrrgl!!! Je viens de passer l'après-midi à essayer d'allumer 3 moniteurs avec un seul PC. La motivation est simple: j'ai toujours une fenêtre cachée au moment où j'aurais besoin de la voir (le log d'erreurs JavaScript par exemple). La solution.... pas si simple.

Enfin si, il y a une solution simple: la carte ATI FireMV avec 4 sorties DVI. Mais ça coute 650 € et c'est pas gagné que je puisse faire passer ça en note de frais! :roll:

Du coup j'ai essayé de ruser... J'ai une carte mère ASUS A8N-SLI Premium. C'est une carte SLI, ce qui veut dire qu'il y a 2 slots PCI express (PCIe), théoriquement destinés à mettre 2 cartes vidéo identiques afin qu'elles se partagent le boulot et affichent plus de détails plus vites dans les jeux.

Moi je m'en tamponne pas mal d'avoir 2 cartes qui se partagent le boulot pour afficher 1 seule image. Moi ce que je veux c'est 2 cartes qui bossent côte à côte, une qui gère 2 écrans et une autre qui gère un 3ème écran! Il y en a qui ont apparemment réussi à faire ça il y a bien longtemps déjà.

Alors j'avais déjà une carte à base de ATI RADEON X800GT. Je sais, c'est une carte haute performance pour les jeux, mais je n'avais trouvé que ça avec 2 ports DVI. Et puis à côté d'une FireMV c'est presque donné! En réalité je ne sais plus combien elle m'a couté. Ceci dit, il était hos de question de racheter la même pour mettre dans le 2ème slot PCIe, ne serait-ce qu'à cause de l'imposant ventilateur qui fait du bruit (enfin pas tant que ça, mais quand même).

Du coup j'ai acheté une carte PCIe d'entrée de gamme à base de ATI RADEON X300SE en me disant que comme ça le même driver allait gérer les 2 cartes et que ça marcherait forcément mieux.

Ben non. Ya rien à faire. Windows refuse de reconnaitre qu'il y a 2 cartes installées. Pourtant j'ai bien configuré le BIOS et le "ASUS AI Selector" (ils pouvaient pas trouver plus clair... |-|) pour signifier que j'avais 2 cartes vidéo sur mes 2 ports PCIe.

J'arrive à faire marcher la X800 toute seule sur le slot 1.
J'arrive à faire marcher la X300 toute seule sur le slot 1.
Mais dès que je mets les 2 cartes, il n'y a toujours que le X800 qui soit détectée par Windows, et ceci qu'elle soit sur le slot 1 ou sur le slot 2! C'est presque comme si la X300 n'était même pas installée dans le PC (sauf que si je l'enlève du slot 1, le PC refuse de booter, donc quelque part il la voit bien.)

A mon avis il y a un problème entre le BIOS et Windows XP, parce que la 2ème carte n'apparait même pas dans le gestionnaire des périphériques, même pas sous forme d'icône point d'interrogation - périphérique inconnu.

Pfff... déprimant. :(

Du coup je crois que je vais ramener la X300 et voir si il sn'ont pas une pauvre carte PCI (pas express) à la place... :'(